Issue Exporting an Inventor Assembly to a STEP/IGES File

Posted on February 3, 2015 by Mark Lancaster, Synergis Product Support:

Inventor 2014 and 2015 only

A couple of days ago I had a help desk case come across my desk where the user reported their STEP file was incomplete after it was exported from an Inventor assembly. While reviewing the customer’s top assembly I couldn’t determine why it was impacting only these components and not any other ones in the assembly. Could it be graphics card related, size of the exported STEP file, memory issue?  These and a few other thoughts ran through my mind while trying to resolve it.

However, as the user and I dug deeper into the model structure, we noticed all of the missing components belong to sub-assemblies that were saved with a certain design view representation. Meaning at the top assembly, the components were visible but when you opened the actual sub-assembly, the components were turned off. Once the sub-assembly was saved with the correct view representation, the top assembly exported correctly.

As the call was nearing the end, the solution to the customer’s problem just didn’t seem right to me. I kept thinking to myself when I use to export assemblies (using Inventor 2013) to STEP files, I don’t recall it working that way.

So for a test, I created a simple assembly that mimics the user’s original model structure. Since the customer was using Inventor 2014, I started there and was able to reproduce the issue they were seeing.  When I repeated the process in Inventor 2015, same thing happened. However, when I ran the workflow through Inventor 2013, the STEP file exported correctly as I remembered. Upon further review I also realized the exporting issue also impacts IGES files under Inventor 2014 and 2015.

At this time I have reported this issue to Autodesk for resolution. Until a solution is provided for Inventor 2014 & 15, please make sure your sub-assemblies have been saved with the correct design view representation prior to exporting the top assembly to a STEP (or IGES) file.

I want to thank Nicole Stine from Gichner Systems Group for reporting this problem and allowing us to troubleshoot it on her machine.

Until next time…

Mark L.

mark_lancaster_MG_0355 croppedMark Lancaster is a Product Support Specialist on our Helpdesk team working to support customers to create data-rich designs and efficient workflows.  Mark’s most previous experience is as the CAD Design Manager of Pall Corporation, one of our long time customers.  In that position, he was responsible for workstation optimization and design management, established uniform standards for the local and global offices, and developed global systems to control and manage their design data.

Have a question for Mark or any of our technical staff? Contact us, visit the Synergis website or subscribe to our blog.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s